=EXTRAE

consulta Karen Tepas:
cómo hacer una fórmula que si los 10 primeros dígitos de la columna C son igual a 5230450506, porque eso nunca varía, si es así me dé como resultado "Con costo" en columna D y si los primeros 10 dígitos de la columna C son 3777340506, me dé como resultado "Gratis" en columna D.

La fórmula que se me ocurre para la columna F es
=SI("5230450506"=EXTRAE(C4;1;10);"Con costo";"Gratis")


Si entre los números hay una tercera opción, tendrías que usar una fórmula con condiciones =SI anidadas.

1 comentario:

Laura dijo...

Me consulta Natalia:
"Hola, quería aplicar extrae sin función "si"; quiero extraer por ej. de una columna con 20 celdas con numeros de 6 dígitos (201210,(año 2012, mes 10)) sacar en una columna a continuación con sólo el mes. Sldos!"


A B C
1 año mes
2 201210 2012 10

fórmula en B2: =EXTRAE(A2;1;4)
fórmula en C2: =EXTRAE(A2;5;2)

=EXTRAE(texto del cual querés extraer; ubicación del primer dígito que querés extraer;cantidad de dígitos que querés extraer incluyendo el primero)